const regex = /[a-zA-Z0-9\.\|\ \/\:\(\)\<\>\=\-\#\"\,]*\ \(Transaction\ ID\ ([0-9]*)\)[a-zA-Z0-9\.\|\ \/\:\(\)\<\>\=\-\#\"\,]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z0-9\\.\\|\\ \\\/\\:\\(\\)\\<\\>\\=\\-\\#\\"\\,]*\\ \\(Transaction\\ ID\\ ([0-9]*)\\)[a-zA-Z0-9\\.\\|\\ \\\/\\:\\(\\)\\<\\>\\=\\-\\#\\"\\,]*', 'g')
const str = `Transformers: The IDW Collection, Vol. 5 (#82973) stock reduced from 18 to 17.|Order status changed from Failed to Processing.|Authorize.Net CIM Charge Approved: Visa ending in 5991 (expires 06/21) (Transaction ID 60782052346)|Authorize.Net CIM Payment Failed (Status code 2: Error Code: 27 - The transaction has been declined because of an AVS mismatch. The address provided does not match billing address of cardholder. Transaction ID 60782050745) Order status changed from Pending payment to Failed.`;
const subst = `WINNER`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);