// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((介绍|说说|讲讲)(一下|介绍)?)?(#是(什么|啥)(东西|玩意|哪(里|儿)|意思)?|(什么|啥)是#)(啊|呀|呢|阿)?$").unwrap();
let string = "介绍一下#
给我说说#
给我介绍一下#吧
说说#是什么
介绍一下#是啥
什么是#
#是啥啊
|#的?(简介|介绍)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}