$re = '/^((介绍|说说|讲讲)(一下|介绍)?)?(#是(什么|啥)(东西|玩意|哪(里|儿)|意思)?|(什么|啥)是#)(啊|呀|呢|阿)?$/m';
$str = '介绍一下#
给我说说#
给我介绍一下#吧
说说#是什么
介绍一下#是啥
什么是#
#是啥啊
|#的?(简介|介绍)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);