import Foundation
let pattern = #"(?P<number>\d+) (?P<word>\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ABC 123 Book 456 ZZZ 789 KKK XYZ"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<word> \g<number>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)