using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<number>\d+) (?P<word>\w+)";
string substitution = @"\g<word> \g<number>";
string input = @"ABC 123 Book 456 ZZZ 789 KKK XYZ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}