re = /{(\w*[^i])#(^$|.+?)\*(^$|.+?)\*(^$|.+?)}/
str = 'Any words that should be{UH#sentence G*sentence H} excluded {UH#sentence A*sentence B dzqd*sentence C} {UH#sentence D*sentence E*sentence F} any other'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end