$re = '/{(\w*[^i])#(^$|.+?)\*(^$|.+?)\*(^$|.+?)}/';
$str = 'Any words that should be{UH#sentence G*sentence H} excluded {UH#sentence A*sentence B dzqd*sentence C} {UH#sentence D*sentence E*sentence F} any other';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);