$re = '/GB|GB[\w]{2,}$/';
$str = 'BG111111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);