package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`GB|GB[\w]{2,}$`)
var str = `BG111111111111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}