use strict;
my $str = 'España - CIF / NIF jurídico - format validator (only format, no control digit)
P1234567A
P12345670
A12345670
A1234567A
C1234567-A
C12345670
W0034567A
W00345670
V12345678';
my $regex = qr/^(?>[PQRSW]{1}-?\d{7}-?[A-Z]{1})$|^(?>[ABEH]{1}-?\d{7}-?\d{1})$|^(?>[CDFGJNUV]{1}-?\d{7}-?[A-Z0-9]{1})$|^(?>[ABCDEFGHJNPQRSUVW]{1}-?00\d{5}-?[A-Z]{1})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}