import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>[PQRSW]{1}-?\\d{7}-?[A-Z]{1})$|^(?>[ABEH]{1}-?\\d{7}-?\\d{1})$|^(?>[CDFGJNUV]{1}-?\\d{7}-?[A-Z0-9]{1})$|^(?>[ABCDEFGHJNPQRSUVW]{1}-?00\\d{5}-?[A-Z]{1})$";
final String string = "España - CIF / NIF jurídico - format validator (only format, no control digit)\n"
+ "P1234567A\n"
+ "P12345670\n\n"
+ "A12345670\n"
+ "A1234567A\n\n"
+ "C1234567-A\n"
+ "C12345670\n\n"
+ "W0034567A\n"
+ "W00345670\n\n"
+ "V12345678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}