use strict;
my $str = 'So, let’s imagine that we have to check a text field, and there’s no particular information about it in project specifications.
In this case, it’s possible to do the following:
Click on the Submit button without previous text field filling.
Click on the space bar a few times, and then click on the Submit button.
Analyze how many characters you can enter in the field, and then press the Submit button.
Enter the minus sign and as many numbers as you can, and then tap Submit.
Enter all the possible special symbols and click Submit. If you see a message with an error, try to analyze it.
Try to enter the symbols that don’t technically correspond with ASCII, different emoji icons, and click Submit. If you see a message with an error, try to analyze it.
Try the features of the cross-site scripting. For this, you should enter such a script: <SCRIPT>alert(“I hacked this!”)</SCRIPT>. If there is a pop-up after clicking Submit, it means that this field is vulnerable to XSS attack (cross-site scripting attack).
Check if it’s possible to use SQL injections. Enter FOO’); DROP TABLE USERS. But don’t do this with databases of those sites that are in production.';
my $regex = qr/<script\b[^<]*(?:(?!<\/script>)<[^<]*)*<\/script\s*>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}