#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<script\b[^<]*(?:(?!<\/script>)<[^<]*)*<\/script\s*>"
Local $sString = "So, let’s imagine that we have to check a text field, and there’s no particular information about it in project specifications." & @CRLF & _
"" & @CRLF & _
"In this case, it’s possible to do the following:" & @CRLF & _
"" & @CRLF & _
"Click on the Submit button without previous text field filling." & @CRLF & _
"Click on the space bar a few times, and then click on the Submit button." & @CRLF & _
"Analyze how many characters you can enter in the field, and then press the Submit button." & @CRLF & _
"Enter the minus sign and as many numbers as you can, and then tap Submit." & @CRLF & _
"Enter all the possible special symbols and click Submit. If you see a message with an error, try to analyze it." & @CRLF & _
"Try to enter the symbols that don’t technically correspond with ASCII, different emoji icons, and click Submit. If you see a message with an error, try to analyze it." & @CRLF & _
"Try the features of the cross-site scripting. For this, you should enter such a script: <SCRIPT>alert(“I hacked this!”)</SCRIPT>. If there is a pop-up after clicking Submit, it means that this field is vulnerable to XSS attack (cross-site scripting attack)." & @CRLF & _
"Check if it’s possible to use SQL injections. Enter FOO’); DROP TABLE USERS. But don’t do this with databases of those sites that are in production."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")