re = /\d+[.]\d+|\d+|[*]+|[\/]|[+]|[-]|(?:.+[)])/m
str = '1+2+3*510.11**1*(1+1-2+(1-2))+2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end