using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+[.]\d+|\d+|[*]+|[/]|[+]|[-]|(?:.+[)])";
string input = @"1+2+3*510.11**1*(1+1-2+(1-2))+2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}