const regex = /^\s*(\d\d)\:(\d\d)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(\\d\\d)\\:(\\d\\d)\\s*$', 'gm')
const str = `1985.10.25 11:30
1985-10-25 11:30
11:30
11:30
11:30
11:30
11:30
11:30 1985.10.25
aa:bb
11:bb
aa:22
a1:22
1a:22
1a:3a
1a:a3
111:30
1:2
1:20
01:2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}