using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(\d\d)\:(\d\d)\s*$";
string input = @"1985.10.25 11:30
1985-10-25 11:30
11:30
11:30
11:30
11:30
11:30
11:30 1985.10.25
aa:bb
11:bb
aa:22
a1:22
1a:22
1a:3a
1a:a3
111:30
1:2
1:20
01:2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}