$re = '/^[0-9]*$/m';
$str = '0
012
01213545674687';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);