package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]*$`)
var str = `0
012
01213545674687`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}