// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z A-Z]+\d{0,5} ?[a-zA-Z]?").unwrap();
let string = "Oslo gate 20
Oslo gate 39a
Oslo gate 39 a
Oslo Gate
Oslo
30
Oslo gate49a
Oslo gate 39a
Oslo gate 34a, leil. H0205
leil. H0205, Oslo gate 34a";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}