const regex = /^[a-z A-Z]+\d{0,5} ?[a-zA-Z]?/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z A-Z]+\\d{0,5} ?[a-zA-Z]?', 'mg')
const str = `Oslo gate 20
Oslo gate 39a
Oslo gate 39 a
Oslo Gate
Oslo
30
Oslo gate49a
Oslo gate 39a
Oslo gate 34a, leil. H0205
leil. H0205, Oslo gate 34a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}