re = /^[1]([123456789ABCDEFGHJKLMNPQRSTUVWXYZabcdefghijkmnopqrstuvwxyz]*)$/
str = '1CGmVVunqjoG6WGBn4FSEJWRTvzzWc7gv6'
# Print the match result
str.match(re) do |match|
puts match.to_s
end