package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[1]([123456789ABCDEFGHJKLMNPQRSTUVWXYZabcdefghijkmnopqrstuvwxyz]*)$`)
var str = `1CGmVVunqjoG6WGBn4FSEJWRTvzzWc7gv6`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}