re = /([+55]{3})([(]?[0]?[1-9]{2}[)]?)[9]?([1-9]{4})-?([0-9]{4})/
str = '+55(021)92948-9683'
# Print the match result
str.match(re) do |match|
puts match.to_s
end