package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([+55]{3})([(]?[0]?[1-9]{2}[)]?)[9]?([1-9]{4})-?([0-9]{4})`)
var str = `+55(021)92948-9683`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}