// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[(?:[a-zA-Z0-9]{0,4}:?){1,8}\]|\[(?:[a-zA-Z0-9]{0,4}:?){1,4}(?:[0-9]{1,3}\.){3}[0-9]{1,3}\]").unwrap();
let string = "[::1]
[:a:1]
[:bh:lh:1]
[1:1:fEd1:1:abdc:1]
[::ffff:192.0.2.128]
[0000:0000:0000:0000:0000:0000:0000:0001]
[2001:0db8:0000:0000:0000:ff00:0042:8329]
[2001:db8:0:0:0:ff00:42:8329]
[2001:db8::ff00:42:8329]
[2001:0db8:0000:0000:0000:ff00:0042:8329]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}