package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(\/[a-zA-Z]+)\/)`)
var str = `/Users/fab815d3-76c7-4ea1-890f-53fcf97394bf/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}