re = /(\{\{[\s]*.*?[\s]*\}\})/
str = 'test {{sss}} s {{rrr}} dkdksl {{dds}} {{ dhre }} {{je ss}} '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end