$re = '/(\{\{[\s]*.*?[\s]*\}\})/';
$str = 'test {{sss}} s {{rrr}} dkdksl {{dds}} {{ dhre }} {{je ss}} ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);