const regex = /(http|https):\/\/([a-zA-Z-]+).([a-z]{2,}):?([0-9]{4})?((\/[a-zA-Z0-9?=]+){0,})(#[a-zA-Z0-9_-]{0,})?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http|https):\\\/\\\/([a-zA-Z-]+).([a-z]{2,}):?([0-9]{4})?((\\\/[a-zA-Z0-9?=]+){0,})(#[a-zA-Z0-9_-]{0,})?', 'g')
const str = `https://yandex.ru:7890/video/455#hash_tag`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}