import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https):\\/\\/([a-zA-Z-]+).([a-z]{2,}):?([0-9]{4})?((\\/[a-zA-Z0-9?=]+){0,})(#[a-zA-Z0-9_-]{0,})?";
final String string = "https://yandex.ru:7890/video/455#hash_tag";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}