const regex = /(?<!@)\b((http(s)?:\/\/)?((\d+)\.)?[a-zA-Z0-9.-]+\.[a-zA-Z]{2,})(\/[^\s]*)?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!@)\\b((http(s)?:\\\/\\\/)?((\\d+)\\.)?[a-zA-Z0-9.-]+\\.[a-zA-Z]{2,})(\\\/[^\\s]*)?\\b', 'gm')
const str = `https://regex101.com/
http://regex101.com/
http:127.0.0.1
regex101.com
example.com.au
info@email.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}