import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!@)\\b((http(s)?:\\/\\/)?((\\d+)\\.)?[a-zA-Z0-9.-]+\\.[a-zA-Z]{2,})(\\/[^\\s]*)?\\b";
final String string = "https://regex101.com/\n"
+ "http://regex101.com/\n"
+ "http:127.0.0.1\n"
+ "regex101.com\n"
+ "example.com.au\n"
+ "info@email.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}