package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?<client>.*)###(?<company>[^_]*)_(?<typology>[^_]*)_(?<period>[^_]*)_(?<uid>ID\d*).pdv\Z`)
var str = `0587###02511020162_LG_2019M01_ID4.PdV`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}