using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<client>.*)###(?<company>[^_]*)_(?<typology>[^_]*)_(?<period>[^_]*)_(?<uid>ID\d*).pdv\Z";
string input = @"0587###02511020162_LG_2019M01_ID4.PdV";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}