$re = '/^(1?)(?:((\s?\(\d{3}\)\s?|\s?\d{3}\s?)\-?\d{3}\s?\-?\d{4}$))/m';
$str = '555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
1 (555) 555-5555
2 (757) 622-7382
(6054756961)
55555555
123**&!!asdf#
555-5555
1 555)555-5555
(6054756961)
(555-555-5555
555)-555-5555
(275)76227382';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);