const regex = /^(1?)(?:((\s?\(\d{3}\)\s?|\s?\d{3}\s?)\-?\d{3}\s?\-?\d{4}$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(1?)(?:((\\s?\\(\\d{3}\\)\\s?|\\s?\\d{3}\\s?)\\-?\\d{3}\\s?\\-?\\d{4}$))', 'gm')
const str = `555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
1 (555) 555-5555
2 (757) 622-7382
(6054756961)
55555555
123**&!!asdf#
555-5555
1 555)555-5555
(6054756961)
(555-555-5555
555)-555-5555
(275)76227382`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}