# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[)(\d+)(\].*')(.+)(')"
test_str = (" [1] = 0 'NumProgPlc' \n"
" [2] = 3 'PadCode' \n"
" [3] = 2 'TablePos' \n"
" [4] = 1 'CurrentTool' \n"
" [5] = 0 'Loc. Override' \n"
" [10] = .200000 'PlaceDelay' \n"
" [11] = .300000 'PickDelay' \n"
" [12] = .150000 'ChamfersChkDelay' \n"
" [15] = -107.575500 'xLpos' \n"
" [16] = 398.586304 'yLpos' \n"
" [17] = 277.373779 'zLpos' \n"
" [18] = 90.000000 'RotApproNasAlim' \n"
" [21] = 53 'PR Offset Tavola' \n"
" [22] = 110 'PR Sopra Tavola' \n"
" [23] = 267 'DO Magnete ON' \n"
" [24] = 268 'DO Magnete OFF' \n"
" [25] = 243 'DI PresPastTav' \n"
" [26] = 247 'DI PezNoPrelTav' \n"
" [27] = 1 'DO Soffio' \n"
" [28] = 111 'PR Tavola+20' \n"
" [29] = 112 'PR Tavola' \n"
" [30] = 0 '_Prelevato' \n"
" [31] = 0 '_ScartoTav' \n"
" [32] = 0 '_ScartoCtrlUs' \n"
" [33] = 0 '_ScambioTav' \n"
" [34] = 0 '_CaricoTav' \n"
" [35] = 1 'FlagMemPtoNasAli' \n"
" [36] = 244 'DO PezPrelTav' \n"
" [37] = 243 'DO PezScamTav' \n"
" [38] = 242 'DO PezDepoTav' \n"
" [39] = 132 'PR Tavola+50' \n"
" [45] = 229 'DI PezPrelNas' \n"
" [46] = 1 'OK_PRL' \n"
" [50] = 1 'PrioritaNas' \n"
" [51] = 0 'CaricoNas' \n"
" [55] = 0 'Conveyor2Rot180' \n"
" [200] = 3.216000 'TC' \n")
subst = "R\\t\\2\\t\\4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.