#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\[)(\d+)(\].*')(.+)(')"
Local $sString = " [1] = 0 'NumProgPlc' " & @CRLF & _
" [2] = 3 'PadCode' " & @CRLF & _
" [3] = 2 'TablePos' " & @CRLF & _
" [4] = 1 'CurrentTool' " & @CRLF & _
" [5] = 0 'Loc. Override' " & @CRLF & _
" [10] = .200000 'PlaceDelay' " & @CRLF & _
" [11] = .300000 'PickDelay' " & @CRLF & _
" [12] = .150000 'ChamfersChkDelay' " & @CRLF & _
" [15] = -107.575500 'xLpos' " & @CRLF & _
" [16] = 398.586304 'yLpos' " & @CRLF & _
" [17] = 277.373779 'zLpos' " & @CRLF & _
" [18] = 90.000000 'RotApproNasAlim' " & @CRLF & _
" [21] = 53 'PR Offset Tavola' " & @CRLF & _
" [22] = 110 'PR Sopra Tavola' " & @CRLF & _
" [23] = 267 'DO Magnete ON' " & @CRLF & _
" [24] = 268 'DO Magnete OFF' " & @CRLF & _
" [25] = 243 'DI PresPastTav' " & @CRLF & _
" [26] = 247 'DI PezNoPrelTav' " & @CRLF & _
" [27] = 1 'DO Soffio' " & @CRLF & _
" [28] = 111 'PR Tavola+20' " & @CRLF & _
" [29] = 112 'PR Tavola' " & @CRLF & _
" [30] = 0 '_Prelevato' " & @CRLF & _
" [31] = 0 '_ScartoTav' " & @CRLF & _
" [32] = 0 '_ScartoCtrlUs' " & @CRLF & _
" [33] = 0 '_ScambioTav' " & @CRLF & _
" [34] = 0 '_CaricoTav' " & @CRLF & _
" [35] = 1 'FlagMemPtoNasAli' " & @CRLF & _
" [36] = 244 'DO PezPrelTav' " & @CRLF & _
" [37] = 243 'DO PezScamTav' " & @CRLF & _
" [38] = 242 'DO PezDepoTav' " & @CRLF & _
" [39] = 132 'PR Tavola+50' " & @CRLF & _
" [45] = 229 'DI PezPrelNas' " & @CRLF & _
" [46] = 1 'OK_PRL' " & @CRLF & _
" [50] = 1 'PrioritaNas' " & @CRLF & _
" [51] = 0 'CaricoNas' " & @CRLF & _
" [55] = 0 'Conveyor2Rot180' " & @CRLF & _
" [200] = 3.216000 'TC' " & @CRLF & _
""
Local $sSubst = "R\t\2\t\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)