// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(POST|CONNECT|GET)\s(.*)\s(HTTP.*)").unwrap();
let string = "CONNECT google.com:443 HTTP/1.1
POST https://myim3app.indosatooredoo.com/api/v1/profile/get HTTP/1.1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}