import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(POST|CONNECT|GET)\\s(.*)\\s(HTTP.*)";
final String string = "CONNECT google.com:443 HTTP/1.1\n"
+ "POST https://myim3app.indosatooredoo.com/api/v1/profile/get HTTP/1.1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}