$re = '/(?:0[xX])?[0-9a-fA-F]+/';
$str = '0x56 0xdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);