const regex = /(?:0[xX])?[0-9a-fA-F]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:0[xX])?[0-9a-fA-F]+', '')
const str = `0x56 0xdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}