const regex = /^(((\d{0,16})\.\d{1,16})|([0-9]{1})|([1-9]{1}\d{0,15})|[1-9]{1,3}(,\d{3}){1,}|(([1-9]{0,3},(\d{1,3}))*(\.\d{1,16}))|([1-9]{1,3},\d{3}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((\\d{0,16})\\.\\d{1,16})|([0-9]{1})|([1-9]{1}\\d{0,15})|[1-9]{1,3}(,\\d{3}){1,}|(([1-9]{0,3},(\\d{1,3}))*(\\.\\d{1,16}))|([1-9]{1,3},\\d{3}))$', 'gm')
const str = `---------------------------------------------
SHOULD PASS
---------------------------------------------
- REGULAR INTEGER---------
1
0
- REGULAR INTEGER MAX 16---------
1234567890123456
- DECIMAL LEADING DOT---------
.22222
- DECIMAL WITH LEADING NUMBER---------
1.22222
- 1k SEPARATOR ---------
1,220
- 1k SEPARATOR AND DECIMAL ---------
1,111.0
1,111,111.0
1,111,000,000,000.0
1,000,000,000.1234567890123456
- 1k SEPARATOR MAX 16 excluding DECIMAL---------
1,111,000,111,000,111
- DECIMAL MAX 16 ---------
0.1234567890123456
- NUMBER MAX 16 and DECIMAL MAX 16 ---------
1234567890123456.1234567890123456
---------------------------------------------
SHOULD NOT PASS
---------------------------------------------
- INT STARTING WITH ZERO
00
0123
- INT LEADING ZERO WITH COMMAS---------
0,222
- INT STARTS WITH COMMA ---------
,111
- INT ENDING WITH COMMAS---------
0,222,
- TOO BIG INT 17 numerals ---------
12345678901234567.123456
- TOO BIG DECIMAL 17 numerals ---------
123456.12345678901234567
- DECIMAL AND COMMA REVERSED
1.220,220
- INT ENDS WITH DECIMAL ---------
1,111.
1111.
- MULTIPLE DECIMAL ---------
1.22.22.22.22.
- HAS TEXT ---------
xyc1235xya
xyc 1235 xya
123 xyc 1234
123xyc1234
.asd1223.123,234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}