package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?i).*(?P<fileExt>\.mka)$`)
var str = `[TxxZ&A.I.R.nesSub][Library_Wars][The_Last_Mission][BDRIP][1920x1080][HEVC_AC3x2].mka`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}