using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?i).*(?P<fileExt>\.mka)$";
string input = @"[TxxZ&A.I.R.nesSub][Library_Wars][The_Last_Mission][BDRIP][1920x1080][HEVC_AC3x2].mka";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}