$re = '/(?i)(?:(?<=^|\s)(?=\S)|(?<=\S|^)(?=\s)){0}(?:(?<=\S)(?=\s|$)|(?<=\s)(?=\S|$))/';
$str = 'ally can be chaallnged {ALL} tested all';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);