#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:(?<=^|\s)(?=\S)|(?<=\S|^)(?=\s)){0}(?:(?<=\S)(?=\s|$)|(?<=\s)(?=\S|$))"
Local $sString = "ally can be chaallnged {ALL} tested all"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")