$re = '/^([a-z])(\w*)$/m';
$str = 'abc
i10n
abcабд
abc.3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);