package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z])(\w*)$`)
var str = `abc
i10n
abcабд
abc.3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}